TangStyle Pro主题

ė 1,070 6 0

TangStyle Pro主题结合多个主题功能,有注册功能,登录功能广告PC,移动随心,三种布局,网址导航、博客布局以及CMS布局。自适应等等。TangStyle Pro主题主要结合了懿古今 three 1.08 – 3.2版本的功能,包括主题选项,弹窗功能,弹窗功能的基础上我增加了综合搜索功能,字号大小等功能。幻灯片方面,我增加了显示置顶文章还是自定义幻灯内容还有就是等等。原tangstyle主题我修改了评论,之前的太单调了,增加了显示访客 UA 信息。管理员评论使用前台经典编辑器功能,以及防机器人评论数字验证功能。

更新记录

4月15-19日

  1. 文章内页做了些许小优化
  2. 遇到的困难是没有找到,打开网站弹出广告按IP或者时间间隔的代码。像知更鸟博客一样,但更更鸟博客的那个代码有两个js文件,我觉得太大了,放弃。只找到了刷新就有广告,这样不利于用户体验,所以放弃。

4月15日

  1. 添加分类置顶、推荐小工具
  2. 更新所有文章列表

4月9日

  1. 优化转载来源以及部分css

4月4日

  1. 修正移动端段落广告

4月2日

  1. 增加文章商品,可在发布页设置单独商品购买链接。如:链接
  2. 修正移动端段落广告

3月30

  1. 优化搜索

3月20

  1. 删除之前的404页面,重新布局
  2. 改变文章页面的tag标签位置

3月15

  1. 在CSS上做了些小小优化
  2. 运行天数做了数据化处理
  3. 增加内容页段落广告,数据化,直接在主题选项内添加。比之前在模板函数 (functions.php)内添加更方便,并加了移动与PC端

3月14

  1. 增加分类文章边栏显示文章发布日期
  2. 新增PAGE页面侧边栏

3月13

  1. 新增
  2. 改变浮窗滚动位置,更适应用户需求。

3月12

  1. 注册页增加验证
  2. 增加边栏“猜你喜欢”相关文章,是否图片显示。以tag标签,如果没有则显示该分类下的文章。
  3. 文章底部小工具相关文章是否图片显示的优化,以及推荐文章图片显示优化。
  4. 把推荐由原来的如果推荐关闭那么相关文章改为随机,并加入全站要排除的分类,在主题选项内可设置。

3月11

  1. 我在TangStyle主题在原有的功能基础上新增加了三个布局,分别是blog,cms以及网站导航布局。

3月9日

  1. smartideo插件修改适应B站移动网址的识别,以及源网址的添加 例:https://www.yijiexiaomin.com/20334.html
  2. 评论方面方面,新增了管理员可以用前台经典编辑器以及F12。
  3. 边栏小工具方面,增加了分类下的文章,以及指定分类文章
  4. 背景色随时间段变化
  5. 在文章页增加了feed的广告以及文章声明,以及增加页码,弹窗下载,展开等广告可以在主题设置内添加。这些功能是在原THREE主题的基础上移植。如图

主题设置新增了移动广告以及PC广告,wordpress自动识别,增加是否幻灯显示,文章页内感兴趣文章推荐显示与否。以及CMS广告的设置。把原有的幻灯内容直播改成置顶文章显示。当然你可以自定义内容,可以在后台选择是置顶文章还是自定义。

主题选项是移植于three主题,在原有基础上并新增了些功能
新增了些短代码,如超链接等等。整体上来讲这个主题可以了。这个主题可以说是PRO版了,原主题大家可以去下载看看与本站修改后的效果区别。
由于文采不好,所以就写这么多。

原主题下载地址:

下载地址1:https://github.com/jarvis-tang/TangStyle/archive/master.zip
下载地址2:https://gitee.com/pmtangjie/TangStyle/repository/archive/master

原主题作者官网:

https://tangjie.me/tangstyle

后话:
▼展开可见

弃three主题的原因是这个主题 经过N次加工后,反而BUG多了,而且臃肿,还有就是后来不知道那个文件染上了后门。今年3月偶尔在gitee.com上看到唐杰的主题,当然也用过云落的,git主题不好用的原因是多处加密,稍微改一下功能就无法正常运行,出错。而且我想结合three主题的功能无法实现,于是放弃云落,选择最原始的tangstyle主题进行修改, 这个主题是因为小而且简单,清晰,是一款非常简化的一个主题。只是在评论模板上下了些功夫,主要原因还是不太懂PHP,只是搬运。在视觉UI上做了些优化,做到尽可能看起来舒服。这个主题不适合PHP 7.2以上版本。当然懂的人,可以随便改一下就OK了。因为PHP7.2版本升级了,所以一些语句会出现错误。当然用7.2以下也不是不行,想想5.6之前的版本都用了那么多年,何必现在用上了7呢。

评论区 (0 条评论/1,070阅) 网友评论仅供其表达个人看法,并不表明一介小民立场。